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Leica P40 scan colourisation with iSTAR HDR images
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The iSTAR 360 degree camera provides rapid, 
automatic HDR (High Dynamic Range) 360 
imaging and can be used as a standalone device 
or for colourisation of point clouds created by 
spherical terrestrial scanners. Although Leica’s 
P40 scanner can provide internal HDR colour 
capture, iSTAR can be used to provide HDR 
imagery with more exposure steps and with 

reduced capture time. A project was undertaken 
to scan and image the Glasgow University 
Building, using both technologies, to show 
their combined capabilities. The results of the 
project showed that iSTAR provides the ability 
to efficiently capture HDR colour and accurately 
combine this with the scan data for significantly 
improved 3D visualisation and time saving.

NCTech iSTAR 360 camera to provide rapid HDR imaging 
for Leica P40 point cloud colourisation
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The aim if this report is to show the workflow used to achieve quality 
coloured point cloud using NCTech iSTAR imaging integrated into Leica 
Cyclone 9.1 and its advantages.

01. Software installation.
02. Fieldworks.
03. Office-work.
04. Results.
05. Colourisation using iSTAR data against laser scanner internal camera.
06. Leica TrueView.
07. Conclusion.
08. Acknowledgements.

01. Software installation
Installing Leica Cyclone:
hds.leica-geosystems.com/en/Support-Downloads-Cyclone-
Downloads_27054.htm

02. Fieldworks
Working with NCTech solutions is the easiest, most accurate and 
highest speed method of colouring point clouds with iSTAR images:

02.01. PLANNING SCAN STATIONS no change to standard process for 
scanning with or without colour.

02.02. CAPTURING POINT CLOUDS with the Leica P40, select the Laser 
Scanner resolution you consider most suitable for the job as in normal 
use. NCTech solutions work irrespective of scan resolution.

Img. 02.01 and Img. 02.02 LaserScanner and iSTAR station.

02.03. CAPTURE iSTAR IMAGES by replacing the P40 with the iSTAR¹ 
camera each scan station, and capture 360 images in full colour. 

NCTech supply adaptor rods with a Tribrach quick release repeatable 
connector to accurately and quickly locate iSTAR at the same central 
capture position as the scanner. iSTAR has different HDR modes 
enabling single exposure, five exposure and nine exposure 360 
images to be created. Five exposure HDR imaging was used here and 
additional capture time was approximately 30-75s² per scan position. 
iSTAR’s on camera interface is designed to be like a regular automatic 
digital camera. Knowledge of photographic techniques is not required 
with iSTAR which automatically calculates the most suitable exposure 
value taking into account the entire 360 scene. Capture time saving 
is around 8-10 minutes per station compared to taking images with 
laser scanner internal camera. Typical comparative capture times 
are 12-14 minutes per station (point cloud scanned + internal camera 
images) against 5-6 minutes per station (point cloud scanned + iSTAR 
data).

Img. 02.03. Adaptor rod and Tribrach setting to achieve the right 
position for works with Leica P40 laser scanner.

03. Office-work
The whole colourisation workflow is fully integrated inside Leica 
Cyclone 9.1.

03.01. OPEN SCAN DATA IN LEICA CYCLONE.

Img. 03.01 Editing preferences window the first time the user opens 
Leica cyclone.

1 - NCTech recommend using its adaptor poles to accurately locate the camera in the correct 
position, different adaptors are used for other laser scanning systems (Leica, Faro,Trimble, 
Topcon, Surphaser, Z+F, etc).

2 - The full iSTAR capture process includes “Analysing time”, “Capturing time” and “Saving time”. 
During saving time the “OK to move iSTAR” message will appear on the iSTAR screen, at which 
point iSTAR can be moved to the next capture position.. For this reason in this example 30-75s 
doesn’t include “Saving time”.
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The first time you run Leica Cyclone, you should turn off Survey 
mode since it displays the individuals scans in their own folders. 
Edit>Preferences>Scan>Survey Mode: No. Check that level is set to 
default.

To import raw files from a scanner, you need to first create a Cyclone 
database.
Configure> database>add.Add any filename that you choose. Leave 
Database Filename field empty (no Cyclone database has been 
created yet).

Img. 03.02. Database creation in Leica Cyclone 9.1.

Now, you can import the scan data to the new database which has 
been created before.

File>Import>Import ScanStation Data> Import ScanStation Project to 
import scan station data for a new project.

Img. 03.03. Import StationProject in Leica Cyclone 9.1.

When importing scan data into cyclone ensure you have selected 
“remove mixed pixels” during data import. This will reduce the 
amount of noise.

Img. 03.04. Import StationProject parameters in Leica Cyclone 9.1.
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03.02. REGISTRATION INTO LEICA CYCLONE
Select your project folder under your data base and click 
“Create>Registration” Double click on registration icon to open it.

Img. 03.05. Registration creation in Leica Cyclone 9.1.

Img. 03.06. Registration window in Leica Cyclone 9.1.

Once registration has been created you can add your scans clicking 
ScanWorld>Add and selecting all scans you want to register in the 
emergent window.

Img. 03.07. Adding scans to the registration in Leica Cyclone 9.1.

If targets have not been used, as in this case of study, you must 
manually identify common points or areas between two scans. You 
can do this using the “Cloud Constraint Wizard” by selecting those 
point clouds which have common areas (Cloud Constraint> Cloud 
Constraint Wizard) or you can do it using “Visual Registration” (Visual 
registration>Visual alignment).

Img. 03.08. Cloud Constraint Wizard in Leica Cyclone 9.1.

Img. 03.09. Visual alignment in Leica Cyclone 9.1.

To calculate the errors, click Registration>Register. You can check the 
error results at “Constraint list” tab. Once the error values were ok for 
you, click Registration> Create Scanworld/Freeze Registration.

Img. 03.10. “Constraint list” tab in Leica Cyclone 9.1.
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To view the data Registration>Create and Open ModelSpace.

Img. 03.10. Registered Point cloud in Leica Cyclone 9.1.

03.02 COLOURISATION INTO LEICA 
CYCLONE USING iSTAR DATA
After registering the point clouds you can then colour them using 
iSTAR raw data directly within Leica Cyclone from version 9.1. This 
process does not require any pre-processing of images or exporting 
of point clouds in *.e57 format. The whole process of colourisation is 
done within Leica cyclone 9.1 and is totally integrated.

Before starting the colourisation process, ensure registration is 
correct with no duplicates or alignment error, otherwise mismatching 

between iSTAR data images and point clouds may occur.

Img. 03.11. Example of partial mismatching between point cloud and 
colourisation data in Leica Cyclone 9.1.

Img. 03.12. Example of partial mismatching between point cloud and 
colourisation data in Leica Cyclone 9.1.

Img. 03.13. Example of general mismatching between point cloud and 
colourisation data in Leica Cyclone 9.1.

To colourise your point cloud you need to import the iSTAR raw data 
file into Cyclone as Panoramic Image and match each iSTAR image 
data with the corresponding scan station. You can then apply the 
image to the point cloud.

Firstly, import iSTAR data by using the option corresponding to 
panoramic images by clicking the right button mouse >Import 
Panoramic Images on the main folder database. An emergent window 
will appear in which iSTAR main folder need to be selected.

Img. 03.14. Import iSTAR image raw data folder in Leica Cyclone 9.1.
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Secondly, the “Match image to Scans” window will appear 
automatically where a scan and image data preview are shown. 
Match each image data to the corresponding scan station. Lock 
each correspondence by clicking on “Lock” button. If “Lock” button is 
pressed without any pre-selection image, scan data matching will be 
automatically done following the proposed order. Thus, locked pairs 
will be moved to the “Locked” tab.

Img. 03.15. iSTAR: Leica P40 data matching in Leica Cyclone 9.1.

Once the scan station scan data is matched, click on “OK” to launch 
the data alignment process. When complete the “Import Panoramic 
Images” window will appear. Select “OK” to import the iSTAR data in 
cube format. Finally, just apply the colour to the images by right clicking 
on the main project folder and selecting “Batch Apply MultiImages”.

Img. 03.16. Import iSTAR image raw data folder in Leica Cyclone 9.1.

The same workflow for both import data and colourisation can be 
applied to a single scan station by right clicking on the scan station 
and selecting “Import Panoramic Images” or “Apply MultiImages”.

Img. 03.17. Point cloud colourisation by using “Batch Apply 
MultiImages” comand in Leica Cyclone 9.1.

04. Results
Coloured point clouds are obtained following described workflow. 18 
Scan and iSTAR stations were used to obtain a merged coloured point 
cloud of Glasgow University Building. Results are showed in Leica 
cyclone 9.1. and also 3rd party software.

Img. 04.01. and Img. 04.02. Visualisation of Coloured Point clouds in 
ModelSpace of Leica Cyclone 9.1.
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Img. 04.03. Visualisation of coloured point clouds with iSTAR data in 3rd party software. General view.

Img. 04.04. Visualisation of coloured point clouds with iSTAR data in 3rd party software. Detail.
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05. Colourisation using iSTAR data 
compared to using internal laser 
scanner camera
As it is shown in the previous section, it can be observed (Img. 04.03 
and Img. 04.04) that the representation of the colour in Leica Cyclone 
is different compared to visualisation using a 3rd party software. 
In this section the difference of colourisation using iSTAR data and 
internal laser scanner camera is analysed in both Leica Cyclone and 
3rd party software.

Img. 05.01. Visualisation of Coloured Point clouds with iSTAR data in 
TruView from Leica Cyclone 9.1.

Img. 05.02. Visualisation of Coloured Point clouds with laser scanner 
internal camera data in TruView from Leica Cyclone 9.1.

Looking at Img. 05.01 and Img. 05.02 it can be observed that iSTAR 
data coloured point clouds give improved visual resolution for any 
occluded area through the interpolate and fill occluded areas function. 
This functionality is automatic within cyclone during colourisation, 
and corresponds to one of the several options that can be selected in 
NCTech ColourCloud.

Img. 05.03. Panorama corresponding to the raw data applied to the 
comparison station.

As we can see looking at the Img. 05.03. the representation of colour 
corresponding to iSTAR data inside Leica Cyclone looks different to the 
processed panorama belonging to the same raw data.

Thus, results obtained following different workflow for the same 
station are also compared in 3rd party software. As it is shown at Img 
05.04 and Img. 05.05 the representation of colour in this 3rd party 
software matches with the corresponding panorama (Img. 05.03).

This allows us to compare the quality provided by each image source 
under the same conditions.

Img. 05.04. Visualisation of Point clouds with iSTAR data using NCTech 
ColourCloud in 3rd party software.

Img. 05.05. Visualisation of Point clouds with iSTAR data using Leica 
cyclone to colourisation in 3rd party software.

Img. 05.06. Visualisation of Point clouds with laser scanner internal 
camera data using Leica cyclone to colourisation in 3rd part software.

To conclude the comparison, observing the images Img. 05.04. 
Img. 05.05 and Img. 05.06 corresponding to the same station and 
visualizing in the same 3rd party software it can be noted that the 
results obtained from iSTAR data processed in NCTech ColourCloud or 
Leica Cyclone 9.1 have little discernible difference, however the using 
laser scanner internal camera gives lower visual quality.
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06. Leica TrueView
To view shared data with Microsoft Internet Explorer it is necessary 
to install the TrueView plugin for Internet Explorer which can be down-
loaded from hds.leica-geosystems.com/en/Leica-TruView_63960.htm

To create a TrueView, open the ModelSpace to be shared and position 
the model so that all scan positions can be seen, this will be the “Site 
Map”. Then, go to File>Publish Site Map, select or create the corre-
sponding folder and the Scan World and a “Site Map Settings” window 
will appear.

Img. 06.01. Visualisation of  point clouds with laser scanner internal 
camera data using Leica cyclone to colourisation in 3rd part software.

Img. 06.02. Site Map Settings window within Leica Cyclone.

From this “Site Map Settings” window you can access to “TrueView 
Settings”. Ensure that in “Color Map Settings” your model is set to 
“Color from Scanner”.

Img. 06.03. TrueView Settings window within Leica Cyclone.

Img. 06.04. Color Map Settings window within Leica Cyclone.

Img. 06.05. TrueView for Internet Explorer.

Once the TrueView is created, click SiteMap.htm to open the project. 
The same exported data can be used within TrueView Global with no 
plugin required. For further information about TrueView Global visit 
www.leica-geosystems.co.uk/en/Leica-TruView-Global_106856.htm
and truviewglobal.leica-geosystems.com/welcome
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07. Conclusion
Coloured point clouds can be obtained through using iSTAR for 
image capture, then following the scan data colourisation method 
as described here. In the case described in this Application Note, the 
visualisation of coloured data in Cyclone could be improved compared 
to 3rd party software.

Despite this, working with NCTech solutions combined with the 
Leica P40 Laser Scanner for point cloud colourisation is considered 
advantageous to alternative techniques for a number of reasons:

Only one iSTAR shot is needed to colour the entire scene at each view 
instead of multiple shots and images per position. This means less 
time on site and also eliminates patchy colourisation experienced 
where individual images are optimised for their omnidirectional view, 
then combined.

Knowledge of photography techniques is not needed since iSTAR 
analyses the whole scene and work out the most suitable camera 
settings for the full 360 view.

Simple use, minimal training. iSTAR and NCTech software are 
designed to be highly automated and user friendly, with minimal 
training required.

Automatic overlay of iSTAR images to point clouds, avoiding having to 
manually define common points, eliminating user error and enabling 
batch processing for efficient operation.

High performance output in difficult lighting conditions. iSTAR 
can provide high visual quality images in a wide range of lighting 
environments as a result of the automatic HDR settings and EV range 
of 27 f-stops.

Reduced fieldwork data capture time. iSTAR can provide high visual 
quality images (HDR ON: 5 exposures, HDR PRO: 9 exposures) 
in less time than LaserScanner internal camera (HDR images 
with 3 exposures). Taking a HDR image with iSTAR takes from 
1.50’corresponding to light conditions (4s Analysing + 7s Capturing 
+ 1.39’ Saving = 1.50’ Total to 4.50’ corresponding to dark conditions 
(1.40’ Analysing + 1.20’ Capturing + 1.90’ Saving = 4.50’ Total) 
depending on lighting conditions but it usually takes around 2.00’ on 
average in normal light conditions. Nevertheless, taking photos with 
internal laser scanner camera increases the capturing time with laser 
scanner in 10 minutes on average.

Reduced office time for data processing. iSTAR data from each station 
is converted into 6 different images for Cyclone import whereas 
the internal laser scanner camera provides 259 images per station 
resulting in a longer import time and colourisation process.

Quality of coloured point clouds is improved. iSTAR data produce 
improved visual quality compared to the laser scanner internal 
camera. Further improvements are gained through additional features 
such as “interpolate and fill occluded areas”, automatically applied 
when colourisation is processed in Leica Cyclone 9.1 and other options 
in NCTech ColourCloud.

Fully integrated workflow. NCTech ColourCloud technology is 
integrated within Cyclone from version 9.1 onwards and therefore, 
the user benefits from a workflow within his ususal point cloud 
software with no need to learn new software or change his workflow. 
In addition, benefits from using iSTAR data extends to Leica True 
View where data can be used within the same way as internal laser 
scanner images.
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